Features

**Automatic Multi Channel Display**
View up to 16 channels simultaneously in any mode with callsign detection. Let Airlink Express find the DX for you!

**Online Callbook Lookup**
Fields in the logbook can be automatically filled with online callbook data.

**Country, Continent, Distance and Bearing Information**
When you enter a callsign on the log bar, the country, continent, distance and bearing information is displayed. The same information will appear when you hover over a callsign over the multi channel display.

**Support for Multiple Soundcards**
Multiple soundcards are supported for input and output of sound. You can even select different soundcards for input and output.

**Support for the most Popular Modes**
- PSK31, PSK63, PSK125 and PSK250
- QPSK, Normal and Inverted, various speeds
- MFSK, Normal and Inverted, various speeds
- RTTY, Normal and Inverted

**Radio Control**
Displays to what frequency, band and mode your radio is tuned to and uses this information for logging purposes. Most common radios from Icom, Yaesu, Kenwood, Elecraft and TenTec are supported.

**Center Bandpass Tuning**
Put a selected signal in the center of a filter passband on your radio with a single click of the mouse.

**FSK Keying**
FSK keying for 45 baud RTTY is supported for USB to Serial Adapters and "real" serial ports.

**Macros**
Define macros to make operating more convenient and quicker.

**Keyboard Shortcuts**
Quickly access often used functions and fields.

**Bandpass Filters**
Select from various predefined filter bandwidths from 100Hz to 1200 Hz or build your own by simply dragging the mouse cursor over a portion of the waterfall.

**Waterfall and Spectrum View Simultaneously**
You can choose to see just the waterfall or see the Spectrum Display at the same time to help you find signals.
Simple, Intuitive Interface
The User Interface is Digipan-like, so the learning curve is minimal.

Logging with ADIF Import and Export
You can keep a log in the program and later export it into an ADIF v.2.x formatted file for import into your favorite logging software. You can also import ADIF version 2 formatted log files into Airlink Express.

Replay Last 60, 30, or 15 Seconds
Airlink Express can replay the last 60, 30 or 15 seconds instantaneously of a received signal, so you can decode that missed signal you saw on the waterfall.
End-User License Agreement (EULA)

By installing, copying or possessing this product you agree to be bound by the terms of this EULA.

Grant of License

You are hereby granted the non-exclusive, non-transferable right to use the software, with the following limitations:

You agree not to modify, decompile, disassemble, reverse engineer or otherwise deface any part of the software.

You may not make any portion of the software part of a commercial, not-for-profit or non-profit distribution without written permission of the author.

Liability Disclaimer

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHOR AND COPYRIGHT HOLDER BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
Contacting Me

You can contact me by dropping me an email at alex@kr1st.com.

Please allow for a few days to receive a reply. At times I'm very busy and do not have time to answer personal email right away.
Getting Started

To get up and running quickly with Airlink Express, you will have to configure a few things first. You need to set up your operator profile on the Operator Information panel, set up Airlink Express to use with your soundcard(s) on the Audio Setup Panel and set up serial port PTT keying on the Serial Port PTT Setup Panel. When you have entered the necessary information there, you are ready to use Airlink Express.

The main window exists of several parts.

The Menu Bar allows access to various settings and functions of the program. They mostly contain items that are not frequently accessed.

Frequently accessed functions have been placed on the Tool Bar. This ensures that the most often used functions are only a single click away.

Below the Tool Bar you find the Log Bar. This section is used to gather information about a contact and enter this information in the log book.

The Received Text Window is where all the decoded text appears. This is also the place where you can collect the information needed for logging. This will be discussed in depth in the Receiving topic. The text that has been transmitted will also be placed in this window.

The Transmit Text Window is where you enter the text to be transmitted. When you select a macro from the macro bar, its text will appear here, too. This will be discussed in depth in the Transmitting topic.
Macros can be accessed through the Macro Bar. The buttons on this bar are associated with the function keys on your keyboard. This is why this bar has the same layout as the function keys bar on the keyboard. The content and the caption of a macro button can be changed by right clicking on a macro button. This will open a macro editor which will be discussed in the Defining Macros topic.

Below and to the left of the Macro Bar, you find the multi functional panel. The default panel shows the volume controls:

One slider control each to set the receive and transmit volume. These sliders are associated with the input and output lines selected on the Audio Setup panel. The third slider is to change the intensity of the colors used in the waterfall.

When you click on the Radio tab, you will see the radio controls:

The top of the panel displays the frequency in Hz the radio is tuned to, the band and which mode is used. If no radio control is set up, it will display the values you see above.

The Center Passband buttons are used to put a signal you are tuned to, in the center of the passband of the IF filters in the radio.

Selecting the Grab tab takes you to the Grab Callsign Panel:

This shows you the callsigns Airlink Express recognized in the received text and gives you the option to grab a callsign, delete it, or clear the list. It also allows you to change the order of the callsigns listed.

The Waterfall Window displays the typical waterfall like image of the received signals. However,
you can change this to a spectrum display by clicking on the toggle button on the tool bar.

The little triangle on the waterfall image indicates the transmit and receive frequency. The numbers at the top of the waterfall display indicate audio frequencies. If there are any problems encountered by the MMVARI DSP engine, messages will appear accordingly in the waterfall display. The waterfall or spectrum view setting is saved in the database so that next time you start Airlink Express it will start with the same display.

The Status Bar can be found at the very bottom of the main window. Here we find indicators for the current transmit and receive audio frequency, which mode Airlink Express is operating in, whether or not the AFC is engaged, the IMD of a signal and if we’re in receive or transmit mode.
Operator Information

On this panel you will have to fill out your personal information. All this information can be referred to in your macros.

None of this information is required, but it will make your life easier when setting up your macros.

The QRZ.com Account Information are the credentials you use to change your QRZ.com listing. Airlink Express does not use the QRZ.com subscription service, so do not use the credentials of the subscription service if these are different than the credentials you use to access the QRZ.com web site.
Audio Setup

Audio Setup

In order for Airlink Express to work properly, the audio input and audio output channels need to be set up.

**Windows XP (and older versions) only:**
When Airlink Express starts for the first time you will notice that the Rx and Tx sliders are set at zero volume and are grayed out.

These controls will become available once you selected the proper input and output devices on the Audio Setup menu.

**Selecting Audio Devices**

Airlink Express will discover all the soundcards available on your computer and will present them to you on the Audio Setup panel.

The input and output channels do not have to be on the same sound cards. This is why you can select a different device for input and output. The Input and Output Line drop down lists will change dynamically when you change Input or Output Devices. Select the appropriate Input and Output Lines according to how your interface is connected to your computer.

The Select Input Channel block allows you to select the left channel, the right channel or both...
channels of the selected input.

You can use the sliders next to the waterfall display to set the volume for the input and output channels.

The left slider sets the receiving volume, and the right slider sets the transmit volume.
PTT Serial Port Setup

If you would like to use your radio’s VOX capabilities, then you can skip this setup panel or explicitly select "None" from the serial port drop down list. However, if you choose to use a serial port for PTT keying, then you will have to provide the information where your PTT is connected to your computer’s serial port here.

![PTT Serial Port Setup](image)

Select the appropriate serial port from the drop down list and then check the boxes to the right to indicate which lines are used for the PTT function.
PTT Parallel Port Setup

If you choose to use a serial port for PTT keying, then you will have to select the address of the parallel port you would like to use from the drop down list.

In order to maintain compatibility with many (commercial) interfaces out there, you will have to make sure your interface is that of the TRLog style. Schematics of such interfaces are widely available on the internet.

The PTT signal is available on Pin 16 (Init) and the return path is via Pin 1 (Strobe).
FSK Serial Port Setup

If you prefer FSK keying through the serial port for 45 baud RTTY, then select the correct serial port in this window. You can enter the same serial port as used for PTT keying if you wish.

By default Airlink Express uses software generated FSK. Don't confuse this with AFSK. Using software generated FSK means that the software will provide for the correct timing of the FSK and PTT signals. This will work for true FSK keying using USB to Serial Port adapters and most Serial Port hardware that are truly UART compatible.

Some soundcard interface devices and serial port hardware are capable of generating their own FSK and PTT signals through the hardware. If you have such a device, check the "Use hardware generated FSK" box. The FSK keying signal will be on the TxD pin of the serial port, while the RTS and/or DTR signal will be used for transmit and receive (PTT) switching.

If you use a USB to Serial Port adapter or use a true serial port for FSK and would like to select on which pin the FSK and PTT signals appear, then do not check the "Use hardware generated FSK" box. This will enable the software generated FSK signals and allows you to select which pin will carry the FSK signal and which pin will have the PTT signal. You can then even select to invert the signals.

To facilitate those stations that do not have a monitoring capability and would like to see and hear the FSK tones during transmit a checkbox is available at the bottom of the form. When you check the box "Audio Visual Feedback for FSK", Airlink Express will generate tones and waterfall feedback through the MMVari control. In order to facilitate this, Airlink Express has to generate some extra diddles at the beginning of the transmission and a single tone at the end to synchronize what is actually sent over the air with the audio visual feedback. When audio visual feedback is not needed, then these extra components are not generated in the transmitted
signal. If your radio is capable of generating a monitor signal, then do not check the "Audio Visual Feedback for FSK" check box.
Radio Control

Airlink Express has limited capabilities to control your radio. It can read the frequency, band and mode from your radio and tune your radio in order to bring signals within the passband of the filters you may have available in your radio.

Select Radio Control from the Setup menu and the following window will pop up where you can setup Airlink Express to communicate with your radio. We will assume you have the serial port hardware and cable installed.

Communication

Select the appropriate serial port and baudrate from the drop down lists and then check the boxes below them appropriately in order for your interface to work. Usually the DTR and RTS are selected to be in a “high” position. Then make sure you have the right number of databits, stop bits and parity set up. You can find this information in the manual of your radio. The RTS handshake signal can be enabled on certain Yaesu radios that require it.

Radio

From the Radio drop down list select the radio you want to use. If your radio is not listed, select
one that you think will closely match your radio. When you select "Icom", the Icom Address input box will be enabled. In this box enter the address of your radio in hexadecimal format. You can find this address in your manual. Also select an appropriate Polling Interval in milliseconds. Default is 500ms (0.5 second). This means that Airlink Express will check the radio's frequency every half a second. You can make this polling faster or slower as you allow your computer allows.

Support is offered for the most common Icom, Yaesu, Kenwood, Elecraft and TenTec radios.

**PTT through CAT**

There are two ways to key the transceiver through the CAT port. One method is to use CAT commands. For transceivers that are capable of this, check the PTT by Cat commands check box.

Depending on your CAT interface, you may also be able to use the same serial port for CAT communication and PTT, saving you a serial port. If your interface does not need the RTS and/or DTR lines to provide power to the CAT interface, then these lines can be used to key your transceiver. To activate this, either check the PTT on RTS check box or the PTT on DTR check box.

**Center Passband**

To make use of the Center Passband feature, you have the opportunity to define three center frequencies of the filters inside your radio. These are the frequencies in the middle of the passband as you would see it on the waterfall. So if your radio has a filter centered around 800Hz (CW filter for instance), then you would put the number 800 in the appropriate box. There are three boxes for an Ultra Narrow filter, a Narrow filter, and a Wide filter.
Invoking Macros

Airlink Express is delivered with a set of generic macros which you can change at any time.

Two sets of 12 macros are available, a regular set and an alternate set. In order to select the alternate set, simply click the check box to the right of the macro buttons. You can also press the shift key to select the alternate macro set.

When you check the alternate macro set box, the captions on the buttons will change accordingly.

Macros can be invoked by pressing the corresponding function key, or by clicking the macro button. The macro buttons in the main window are grouped similarly to the function keys on your keyboard as an aid to identify which button corresponds to which function key. Of course you can change the captions of the macro buttons to indicate the associated function key. You can do this on the Macro Definition panel.
Defining Macros

Airlink Express is delivered with a set of generic macros which you can change at any time.

Two sets of 12 macros are available, a regular set and an alternate set. In order to select the alternate set, simply click the check box to the right of the macro buttons as explained in the Invoking Macros topic.

To change a macro definition, just right click on any of the macro buttons. This will start the macro editor which you will use to change the macro content and the caption on the button.

The Key Label field indicates the caption of the macro button. Then below that you find the macro text editor box. You can just type text in the box, but you can also insert macro tags from the macro tags box at the current cursor position.

The Repeat interval allows you to automatically repeat the macro in a specified interval. The interval should be specified in seconds.

In order to insert a macro tag, move the cursor in the macro text box to where you want the tag to appear, select it from the macro tag list on the right, and then click the button. This will place the macro tag at the current cursor position in the macro text box.

Once you're done editing the macro, click the Save button so that the macro will be saved in the database. This will return you to the main window. The Cancel button will take you back to the main window without saving any changes.

Changing the Background Color of a Macro Button

The macro buttons can be colored so that it may help you recognize them quicker. Every macro button can have a different color. Simply click on the "Change Button Color" button at the bottom left of the Macro Editor window and select a color from the color picker window that will pop up.
If you want to change the color back to the silver button color, just check the "Default Color" check box.
**Saving Macros**

Airlink Express allows you to save and load macros. Not only will this aid as a backup, it also allows you to use different macros in different circumstances. For instance, you can have one set of macros for when you are a net control operator, and another for chasing DX.

To save the current set of macros, select the "Save macros" item from the File Menu.

You will be prompted for a location and name of the saved macro set.

Click the Save button and your macros will be saved.
Saved C:\Users\KristA\Desktop\Macros.xml
Loading Macros

To load previously saved macros select the "Load Macros" item from the file menu.

You will be prompted for a location of the macro file you would like to load.

Click the Open button and the new macros will be loaded.
Macros loaded

Macros C:\Users\KristA\Desktop\TestMacros.xml have been loaded
Selecting Modes

Airlink Express is capable of operating in various modes. These are PSK, QPSK (normal and inverted), MFSK (normal and inverted), and RTTY (normal and inverted). You can select these modes through the drop down list on the tool bar.

Most modes are available in different speeds. You select a different speed by selecting one from the Speed drop down list to the right of the mode drop down list.

The available speeds in the Speed drop down list are automatically adjusted for the mode you select.

You can changes modes on the fly, even while transmitting. As you can see, for the MFSK and the RTTY modes are the customary Normal and Inverted modes available. Whichever you select depends on how your transceiver is set up.

MFSK is usually transmitted in USB mode, so if your radio is in USB mode then you'd select "MFSK Normal". If your radio is in LSB mode, then you'd select "MFSK Inverted" mode.

For RTTY it is just the other way around. "RTTY Normal" is used when your radio is in the LSB mode, and "RTTY Inverted" is used when your radio is in USB mode.
Selecting Predefined Bandpass Filter

Airlink Express allows you to select from predefined bandpass filters with bandwidths of 1200Hz (Wide), 500 Hz (Medium), 250Hz (Narrow) and 100Hz (Ultra Narrow). The filter is centered around the currently selected frequency. This gives you the opportunity to quickly filter out neighboring signals that are interfering. Be aware though that a bandpass filter at audio level is not nearly as effective as a bandpass filter in the receiver of your radio.

You can select the filter from the Options menu.

![Filter Selection](image)

A quicker way to select a filter is to select one from toolbar.

![Filter Toolbar](image)

The filter settings are stored in the database. So next time you start Airlink Express, the last selected filter will be active.

To clear the filter selected, you can click on the same filter button again, or click on the filter button with the red X on it. This will clear all filter selections.
Defining Your Own Bandpass Filter

Not only can you select from a predefined set of bandpass filters, you can also define your own.

To do this simply decide where the lower cut off frequency needs to be and point the mouse there on the waterfall. Then press the left mouse button and hold it down. Move the mouse where the upper cutoff frequency needs to be. A green bar will be visible indicating the currently selected portion of the waterfall.

Once you reach the upper cutoff frequency, release the left mouse button and the bandpass filter will be set to the selected cutoff frequencies and is immediately active.

It also works the other way around. You can start at the upper cutoff frequency and then hold the left mouse button down while you move towards the lower cutoff frequency. Just let go of the left mouse button when you're there and the filter will be set up and is active immediately.

To reset the filter, select "None" from the Bandpass filters under the Options menu or from the tool bar. Of course you can select any of the other filters, too. You can also click on the filter button with the red X. This will clear all filter selections.
Adding Log Data

To add a log entry for a contact you will have to fill out the fields in the log bar.

If you enter a callsign that already is in the log, a green check mark will appear above the callsign box:

```
Callsign:  ✓  Nar
  KR1ST
```

If the option "Show log on callsign search" in the options menu is turned on, then the log window will appear with all the prior contacts listed for that callsign.

An **optional log bar** is available by clicking on the icon in the tool bar. This will show the optional log bar on which you can enter more relevant information.

These additional fields are mainly used for DXing, contesting, county hunting etc. The SNRX field is a serial number received field, and the SNTX field is the serial number sent field. These fields do not have to be numeric and can be used for contesting purposes even though Airlink Express is not meant to be contesting software. If you enter a number in the SNTX field, then this will be automatically incremented every time you log a contact by either clicking on the button or when the <LOG> or <LOGANDCLEAR> macro tags are invoked.

Once you enter pertinent information of the contact in the fields of the log bar the save button will become available. When you click on that button the entry will be saved in the log book. The fields will not be cleared however. This is so you can change things and enter a new log entry if you discover a mistake. That way you don't have to enter all the information again.

To clear the fields, simply click the clear button. The search button can be used to search the log. See the [Searching the Log](#) topic.

Note that if Radio Control is enabled and working, then the band drop down selection will follow with the frequency your radio is tuned to. Both the frequency and band from the radio will be logged.
Searching the Log

Airlink Express will look up previous contacts for a callsign if you have the “Find previous contacts” option selected from the Options menu. If the callsign is already in the log, a green check mark will appear above the callsign box once you leave the Callsign field and the logbook will show you those previous contacts.

You can also click the search icon:

Either method will bring up the log book that will display all previous contacts for that callsign.

The number of entries for that callsign is displayed in the navigation bar at the bottom of the log window. To view all log book entries, not just for this callsign, click the “View Complete Log” icon in the status bar of the logbook.

This feature can be turned on and off in the Options menu:
Log Navigation

The logbook can be opened by either clicking on the logbook icon on the tool bar or by clicking on the search button in the log bar as shown in the Searching the Log topic.

A new window will open showing the complete log and it offers many ways to navigate through the log and to make changes to the log.

At the bottom right of the logbook window in the status bar you will find a navigation bar. This bar will allow you to go to a specific entry, page forward or backward through the log, or jump to the beginning or end of the logbook.

To search for a callsign in the logbook, simply enter the callsign in the Search field and hit the enter key. You will then presented with all the log entries for that callsign.

To add an empty log entry at the end of the log, just click on the yellow plus symbol. Then you can fill out the fields accordingly.

You can also delete a log entries by selecting them in the logbook grid and then click the X symbol. You can use the customary Windows selection options (Ctrl-LeftMouseDown, Shift-LeftMouseDown, Ctrl-ArroeKey, etc.) to select log entries, including Ctrl-A, which will select all entries.

You can sort the log in any order and by any column. Simply click the column name to sort the long in ascending or descending order by that particular column.
Changing Logbook View

Airlink Express allows you to change the column width and order in the log book.

To move a column, just click and hold the column header and drag it in front of or behind the column you would like it to appear. The size can be changed by clicking and holding the column separator when the cursor changes to a double arrow. Then move the column separator to the left or right to make the column smaller or bigger.

Below is the result of moving the BAND column all the way to the left and increasing the space for the CALL column:

Changes made to the log book format will be saved for the next time it opens.
Exporting the Log

You can export the log to a file in ADIF 2.0 format through the file menu.

Selecting "Export Log to ADIF" from the file menu will open a file dialog window which will allow you to specify a file name and location to store the file.

Once you click on the Save button, Airlink will export the log in ADIF version 2 format to the specified file. The progress will be displayed by a progress bar.
Now you can import the logbook into your favorite logging program if you wish.

Please note that the complete logbook is exported. Since the ADIF file is a simple text file, you can make changes with any text editor.

To select specific entries to export, open the log, select the entries you want and then right click on an entry:

![Log Book](image)

When you click on "Export selected rows to ADIF" on the context menu that appears, a dialog box will pop up like above asking you where to store the selected entries.
Importing ADIF Log

Besides exporting the log from Airlink Express into an ADIF version 2 formatted file, you can also import an ADIF version 2 formatted file. This can come in handy when you migrate between versions of Airlink, or when you want to import an existing log file.

Simply select the Import Log from ADIF menu item from the File menu.

A file dialog box will pop up so you can select the log file in ADIF format you’d like to import into the current log.

Once you click the Open button, Airlink Express will start the import process. The progress of the import process is shown by a progress bar.
You can verify the log by clicking the Logbook icon on the toolbar.
Backing Up the Logbook

Airlink Express allows you to backup your logbook database. Because this database is rather large (minimum of 5Mb) it will be stored as a zip file in the backup.

To backup the current logbook, select the "Save macros" item from the File Menu.

You will be prompted for a location and name for the backup of your logbook. You can name the backup anything you like.

Click the Save button and your logbook will be zipped up and stored at the location you selected.
Restoring the Logbook

To restore a previously backed up logbook, select the "Restore Logbook" item from the file menu.

You will be prompted for the location and name of the backup file containing your logbook.

Click the Open button and the logbook database will be unzipped and placed where Airlink Express can find it.
Logbook restored

Logbook C:\Users\KristA\Desktop\KR1ST_LogBook.zip has been restored

OK
Printing the Logbook

The logbook can be printed by clicking on the icon on the navigation bar at the bottom right of the logbook. First you have to select the rows that you would like to print.

You can select a single row, multiple rows, or the complete logbook, using the standard Windows selection commands (Ctrl-LeftClick, Shift-LeftClick, Ctrl-A, etc.).

Only the most pertinent columns of the logbook will be printed. You cannot select which columns will be printed. The columns that will be printed are Date, Time, Band, Mode, Name, Call, Name, QTH, RSQ Received, RSQ Sent, and QSL Via. The arrangement and the size of the columns will be the same as on the logbook grid, so you have some influence on how it will look by changing the logbook view.

After you made your selection you can click on the icon on the navigation bar and a window will pop up allowing you to select the printer you’d like to use.

Select a printer and then click the OK button. You will then presented with a preview of the logbook as it will be printed.
When you are sure that you want to print what you see, click on the icon at the top left of the preview window and the logbook will be printed on the printer you selected earlier. You can then click on the X button at the top right of the preview window to close it.

Please keep in mind that trees should be used to support antennas, and should not be used to print logbooks on!
Receiving

To start receiving a signal, click on a signal on the waterfall. The green triangle will center on the signal and the MMVARI DSP engine will immediately start to decode the signal. The audio frequency to which Airlink Express is tuned to is displayed in the status bar.

Instead of clicking on a signal, you can also use the arrow keys to tune up or down the waterfall display. Pressing the left arrow key will tune receiving frequency down 1 Hz at a time, and pressing the right arrow key the tuning frequency will increase by 1 Hz at a time. You can accelerate this by holding the control key down while pressing the arrow keys. This will allow you to tune up or down in 10 Hz increments.

The text decoded by the MMVARI DSP engine will appear in the Receive Text Window, as well all transmitted text. If the mode is set incorrectly, only garbage characters will appear in the receive window.

When the operator clicks in the receive window, the window will stop being updated. This does not mean that reception is being lost, it just means that the display of it stops. This allows you to select text in the receive window to use for logging purposes. To restore the display of received text, simply click somewhere outside the receive window. Nothing will be lost.

If you double click on a word it will be selected and copied into the first available field on the log bar. In general this would be the callsign, but it can be any field, except for the RST fields and the band field.

Another way to fill the fields on the log bar is to select a text in the receive window and right click on it. A menu will pop up giving you several options.

The receive window has some special functions.
You can select “Copy” and then go to a field in the log bar and paste the text into that field, or you can select any of the options below the separator line. If you'd select "Callsign" for instance, then the selected text will be placed in the callsign field on the log bar. Select "Search Log" and the log will be searched for the callsign in the selected text.

If you want to clear the receive window, select the top option of the right click menu.

**Audio Input Level**

To change the receive audio level you will have to select the Volume panel first by clicking on the "Volume tab":

You can change the audio input level with the left most slider. Moving the slider up will increase the input level and moving the slider down will decrease the level. You can observe the effect of this slider on the waterfall.

**Waterfall Gain Level**

Sometimes the input level is just not enough to drive the waterfall to your satisfaction. Even when the Rx slider is all the way up, you still can barely see a signal on the waterfall. This especially happens when you use a fixed level output on your radio and feed that to the Line In of your sound card. To improve the situation you can change the Waterfall Gain Level with the slider just to the left of the waterfall marked "WF Gain". Moving the slider up will intensify the colors on the waterfall and will make signals more visible. Moving the slider down will have the opposite effect.

**Replay the Last 60, 30 or 15 Seconds**

You can replay the last 60, 30 or 15 seconds of the received signal on the waterfall by clicking on one of the replay buttons on the tool bar. The whole "waterfall" will be replayed, not
just the received transmission and it will be replayed at an accelerated speed. That way you can
tune into a signal that already has disappeared from the air, but you’re interested to see what or
who that was. To interrupt the replay press the stop button on the toolbar.

**Level Metering and Squelch Control**

To the right of the waterfall you see a vertical bar that indicates the receive audio level of the
currently tuned signal.

![Squelch Level Indicator](image)

When the indicator turns green, it means the squelch level has been reached. The squelch level
can be set by moving the thin black horizontal line on the level meter up or down with the mouse
(left click and hold while moving the mouse up or down). A gray color indicates that the squelch
level has not been reached and yellow means Airlink Express is in transmit mode.

**Spectrum Display**

The spectrum view can be turned on and off by the button on the tool bar or on the tools
menu. When the spectrum view is turned on you will be able to view the waterfall and the
spectrum display at the same time.

![Spectrum Display](image)

When the spectrum display is turned off the waterfall will take up the space used for the spectrum
display as well so you will be able to view a larger waterfall display.

Under Options>FFT Scale you can select between Squared Amplitude or a 100dB scale for the
spectrum display. The picture above shows the squared amplitude scale and the picture below
shows the 100dB scale:
Transmitting

The **Receiving** topic already showed that you can tune to a signal using the waterfall. Now it’s time to transmit, perhaps to answer a CQ call or to start a CQ call yourself.

You can type the text you want to transmit into the Transmit Text Window. Airlink Express has a so called type-ahead-buffer, which means that you can type the text you want to transmit before you are actually transmitting. This is helpful to start to reply to a station while that station is still transmitting.

Clicking on any of the macro buttons on the Macro Bar will place the interpreted macro text in the transmit window. Interpreted macro text means that the tags in your macros will be replaced by actual text before the macro is put in the transmit buffer.

When you right click in the transmit text window, a menu will pop up giving you a few options.

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>Clear</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Copy</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Paste</strong></td>
<td></td>
</tr>
</tbody>
</table>

To clear the transmit window, and therefore the transmit buffer, select the top option "Clear". You can copy selected text from the transmit window into another application or even into any of the fields of the log bar. The "Paste" option will let you paste selected text from a different application, or even the receive window in the transmit text window.

There are several ways to start transmitting. You can toggle between transmitting and receiving by clicking on the 📢 button on the tool bar. The same can be done by defining a macro that toggles between transmit and receive like one of the default buttons 📢. Right click on that button to see how that button is defined. Another alternative is to start a macro definition with the `<TX>` macro tag. As soon as you press the corresponding button, Airlink Express will start transmitting.

You can stop transmitting immediately at any time by hitting the Escape (ESC) key.
Locking Transmit Frequency

If you’re the net control of a digital mode net, it is handy to be able to lock the transmit frequency, but have the receive frequency being able to vary (AFC). This way the net will not change frequency as everyone will be locking onto the transmit frequency, while the net control will be able to receive stations that transmit slightly off frequency. To enable this feature, click the lock icon on the tool bar. Once this feature is selected you can move the receive cursor around the waterfall, but the transmit cursor will stay put. To disable this feature, just click the lock icon in the toolbar again.
Locking Receive Frequency

If you’d like to lock the receive frequency, click the lock icon \( \text{lock} \) on the tool bar. This will prevent the receive cursor from wandering around due to AFC action. Keep in mind though that if the transmitting station is not stable and moves slightly off frequency during transmission, Airlink Express may stop decoding.

The RX lock is effective only within one mode bandwidth on either side of the current frequency. If, for instance, Airlink Express is in the PSK31 mode and you click on a frequency that is less than 31Hz away from the current frequency, the receive cursor will not move. However, if you click on a signal that is more than 31 Hz away from the current frequency (on either side of the current frequency), the RX cursor will move to that signal. If Airlink Express is in the PSK250 mode and the RX lock is engaged, then you will have to click on a frequency that is 250Hz away on either side of the current frequency before the receive cursor will move.
Split Frequency Operation

If you want to operate in split frequency mode you have to decouple the transmit frequency from the receive frequency. You can do this by right clicking on the waterfall where you want the transmit frequency to be. A second cursor (red) will appear on the waterfall indicating the transmit frequency.

![Split Frequency Example](image)

From now on you can left click to change the receive frequency and right click to change the transmit frequency.

If you want the receive and transmit frequency to be the same again, double-right click or click right twice on the same frequency on the waterfall. The red transmit indicator will disappear.
Tune

If you need a signal to tune your antenna or amplifier, you can click the button on the toolbar. Airlink Express will then transmit a continuous tone at the frequency set on the waterfall display. To stop transmitting this tone, you can click the button again or click the button on the toolbar. Of course hitting the Escape (ESC) key will work, too.
Automatic Frequency Control

The MMVari DSP engine Airlink Express is built on has two AFC functions on board. One is meant to track transmissions that are currently received, and the other is meant to automatically find stations on the waterfall. The former can not be turned on or off. The AFC function that finds stations is what is we're talking about here.

Automatic Frequency Control (AFC) is turned on by default, but can be turned off and on by clicking on the button in the tool bar. The AFC will attempt to find a signal 100 Hz up and down from the frequency you are currently tuned to.

You can turn the AFC on and off also though the Configure menu. This setting is saved in the database, so next time you start Airlink Express, it will be set to what it was last time you used Airlink Express.
**S/N Measurement**

The signal to noise ratio (S/N) can be measured by Airlink Express. You can turn this feature on and off by clicking the button on the tool bar. When it is turned on the S/N value in decibels (dB) will be shown in the status bar. This value gives you some indication of the received signal, although the usefulness depends on many factors. That is however beyond the scope of this text.

This setting is saved, so next time you start Airlink Express, it will be set to what it was last time you used Airlink Express.

The S/N ratio you see in the status bar is a running average of the past 3 seconds of a signal. You will notice that when a signal disappears, or ends, the S/N ratio is still visible and will not drop down to zero. This is so that you can include the S/N measurement in the macro with the `<SN>` macro tag. If the S/N drops down to zero, then a zero measurement will be the result when the macro actually runs. This also prevents you from having to remember to actually start a S/N measurement like you have to in other measurements. What this also means is that a signal must have been received for at least 3 seconds before the S/N is accurate.

When you do a S/N measurement, you can hold the S/N value by clicking on it on the status bar. The background color of the S/N value will change so you know it's holding the value until you release it by clicking on the S/N value in the status bar again.

**Hold:** S/N: 18 dB

**Released:** S/N: 16 dB

This will help you to make sure you get the intended value into the `<SN>` macro tag.

Most digital mode software call this feature an InterModulation Distortion (IMD) measurement, but it really is a S/N measurement. What the software does is measure the difference in signal strength of the received signal with a portion of the side bands next to the signal where the intermodulation distortion would show up. However, since this method does not discriminate between an actual signal in the side bands and noise, it really is not accurate to call this an IMD measurement. Besides, it only measures a small portion of the side bands, and we all have seen these ultra wide signals on the band with many side bands. Only one of those side bands is used for the measurement. So the software can still indicate a halfway decent IMD for that seriously distorted signal while you can see that the IMD is much worse than indicated by the number in dB.

This is the reason why I call this feature an S/N measurement. I suspect this is also why the developer of MMVari calls this a S/N measurement.
Selecting Colors

Airlink Express allows you to change the background and text colors of the Receive Window and the Transmit Window, as well as change the color of the background of the even and uneven channels on the Multi Channel Display (MCD) and the color of the text on the MCD. The text you are transmitting on the RX window can also be given a different color than other received text. Select the color you’d like to change from the Options Menu:

When selected, a so called Color Picker window will pop up, allowing you to select a color:

Once you have selected a color, the color for the selected aspect will immediately change to that color. Make sure you do not choose similar or the same colors for the background and the text or else you will not be able to read anything.
Changing Waterfall Colors

To change the colors on the waterfall, select "Waterfall Palette and Spectrum" from the Options>Colors menu. A window will pop up allowing you to select a different color for each of the waterfall.

There are audio 7 levels you can select a different color for. Level one is the lowest audio level, and level seven is the highest. In this window you can also change the color of the Spectrum display. Just click on the color for each level and a color picker will appear as shown above. Pick a color and do this for all other levels you would like to change the color for. When you are done, click the Save button, and you will notice that colors change immediately on the waterfall.

You can always can restore the original colors by clicking on the "Restore Defaults" button. The default colors closely match the default colors of Digipan.
Selecting Colors

Airlink Express allows you to change the fonts of the text in the Receive Window and the Transmit Window, and also change the font of the text in the Multi Channel Display. Select the font you’d like to change from the Options Menu:

When selected, a so called Font Picker window will pop up, allowing you to select a font:

Once you have selected a font, the font for the selected aspect will immediately change to that new font.
Radio Control

If your radio has the capability of being controlled by a computer and you're setup for it, you can go ahead and configure the radio control interface as described in the Radio Control Setup section.

Once the interface is properly setup, you can see if it works by clicking on the radio tab on the bottom left of the program:

If everything is set up properly and your radio is supported by Airlink Express, then you will see the frequency, band and mode fields populated. When you tune your radio or change modes on the radio, then those changes will be reflected in the appropriate fields.

Note that the band drop down list on the log bar will change corresponding to the frequency your radio is tuned to. The frequency Airlink Express reads from your radio will be entered in the log when you log a contact.
Center Passband Tuning

Airlink Express has the capability to tune your radio so that a selected signal on the waterfall will be in the center of the passband of a filter in your radio. This is useful when you want to employ a more selective filter in your radio to pull out that weaker signal.

In order for this to work, you will have to tell Airlink Express what the center frequencies are for the various filters. Airlink Express allows you to set this up for three filters named Ultra Narrow, Narrow and Wide. You set this up on the Radio Control configuration screen. Of course this function will only work if Radio Control is enabled and properly setup.

If Radio Control is properly set up three or four buttons in the Center Passband Section of the Radio Tab will be enabled.

Once you have selected a signal on the waterfall display that you'd like to put in the center of the passband of a filter, you can click on the appropriate filter button in the Center Passband section. Clicking, for instance, on the U (Ultra Narrow) button will tune the radio to the correct frequency to put the selected signal in the center of the passband of the filter you'd like to employ on your radio. Airlink Express will not select that filter; you will have to do that manually. You will see that the signal is moved on the waterfall and Airlink Express has automatically selected the signal of interest for you.

You can "undo" this by clicking the same button again. Airlink Express will then tune the radio back to where it was and will put the selected signal back on the waterfall where it first was seen.

The three buttons, U, N and W all work the same way. This allows you to set up to three different passband center frequencies. Chances are that all filters have the same passband center frequency. In that case you really only have to define one.

Icom IC-756ProIII Special Feature

The R button is only enabled when you have selected the IC-756ProIII from the Radio Control setup screen. This button works a bit differently than the other center passband buttons in that it not only retunes the radio, but will also select the RTTY twin peak filter available in that radio and switch Airlink Express to the RTTY mode if necessary. Hitting the R button again will return the radio back to where it was first tuned.
Keyboard Shortcuts

Airlink Express has a few keyboard shortcuts which enable you to select certain fields and functions quicker than by selecting them with a mouse. The following shortcuts are available:

**Shift:**

Holding down the shift key will temporarily switch the macro buttons from the default set to the alternate set. Releasing the shift key will return the selection to the default macros again.

**Alt-C**

This will take you to the Callsign field and the callsign will be highlighted for quick editing.

**Alt-G**

This will take the first of the callsigns on the grabbed callsigns list and put it in the Callsign field. If a particular callsign is highlighted (selected) on the grabbed callsigns list, then that one will be placed in the Callsign field.

**Alt-N**

This will take you to the Name field and the name will be highlighted for quick editing.

**Alt-Q**

This will take you to the QTH field and the qth info will be highlighted for quick editing.

**Alt-R**

This will take you to the “RSQ rcvd” field and the RSQ info will be highlighted for quick editing.

**Alt-T**

This will take you to the “RSQ sent” field and the RSQ info will be highlighted for quick editing.

**Alt-B**

This will take you to the Band drop down list.

**Alt-P**

This will take you to the Power field and the power will be highlighted for quick editing.

**Alt-O**

This will take you to the Comment field and the comment will be highlighted for quick editing.

**Alt-S**

This will save the information on the log bar to the logbook if the Callsign field is populated.

**Alt-W**

This will remove all previously entered information from the log bar.
**Alt-L**
This will let you lookup a callsign in the logbook if the callsign field is populated.

**Alt-X**
This will exit the program after confirmation is given.

**Left Arrow**
This will decrease the frequency of the main channel by 1Hz.

**Right Arrow**
This will increase the frequency of the main channel by 1Hz.

**Ctrl-Left Arrow**
This will decrease the frequency of the main channel by 10Hz.

**Ctrl-Right Arrow**
This will increase the frequency of the main channel by 10Hz.
Grabbing Callsigns

Airlink Express can automatically recognize callsigns in the received text and place these on a list for you. This feature is turned on or off on the Options menu. New callsigns will be added to the bottom of the list.

If you'd like to grab a callsign from the list and put it in the Callsign field of the log bar, just select the callsign from the list on the left and click the Grab button. You can also double click on the callsign to do this or use the Alt-G keyboard shortcut. There is also a <GRAB> macro tag to accomplish this from within a macro.

To delete a callsign from the grab list, click on the Del button. The <DELGRAB> macro tag allows you to do this from within a macro.

If you'd like to clear out the whole list, click the Clear button.

You can also change the order of the list by selecting a callsign and then hit the up or down buttons. This will move the selected callsign up or down in the list.

There is also a context menu available on the grab list:

- Clear
- Copy
- Copy All
- Paste
- Cut
- Delete

This context menu (right click) allows you to Clear the list, Copy a selected callsign, Copy All callsigns, Paste callsigns, Cut a selected callsign or Delete a selected callsign.

Net Control

The features of the context menu together with the buttons on the Grab panel make life for a net control operator a bit easier. Airlink Express can populate the list from the check-in callsigns received, or you can paste a list of callsigns into the grab list if you have a list of “regulars” you’d like to poll. Once net members check out you can delete their callsigns from the grab list. This will help you to keep track who is still on the net.
Display Tone or RF Frequency

Airlink Express allows you to display either the tone or the actual RF frequency on the waterfall and spectrum display. This option is available in the Options menu:

When you select to display the tone frequency, you will see a scale displaying the base band audio frequencies in the waterfall and spectrum view:

The radio frequency display will show the frequency on the radio dial:

When the "Display tone frequency" is deactivated, Airlink Express will show a scale displaying the actual RF frequency on the waterfall and spectrum view:
The radio frequency display will then show the actual RF frequency you are tuned to and not the radio dial frequency:

<table>
<thead>
<tr>
<th>7.035.712 Hz</th>
</tr>
</thead>
<tbody>
<tr>
<td>40m</td>
</tr>
<tr>
<td>USB</td>
</tr>
<tr>
<td>Center Passband</td>
</tr>
<tr>
<td>U</td>
</tr>
</tbody>
</table>
Band Configuration

The band configuration is being used for stations that do not have Radio Control, but would like to display RF frequencies rather than tone frequencies on the waterfall and spectrum display.

The band configuration can be changed by clicking on the band configuration option in the Setup menu.

On the band configuration window you can specify for each band the frequency of where the radio is tuned to on that band and what mode (LSB or USB) is used. If you still rather have the tone frequency being displayed for that band, then keep the Tone check box checked for that band.
Make sure the Tone box for a band is unchecked if you want to see the RF frequency on the waterfall and spectrum view. Also make sure you hit the save button so that the new settings will be saved.
Multi Channel Display

The multi channel display can be made visible by clicking on the icon on the tool bar. Clicking it again will make the multi channel display disappear.

For the multi channel display to function correctly, the AFC has to be turned on. You will notice that the AFC will be turned if it was off, and the AFC button will also become grayed out so you cannot turn it off while the multi channel display is activated.

The multi channel display will become part of the RX and TX window when activated.

You will also notice that channel markers are put on the waterfall and spectrum view.

Depending on the mode and speed selection, there are either 16, 8, 4, or 2 extra channels visible.

Airlink Express will automatically start searching for signals to decode. All the text that is decoded by a channel will be placed on a scrolling field right next to the channel indicator (number) in the multi channel display.

You can assist the tuning of each channel by dragging the channel marker on the waterfall or spectrum view to the desired signal. This can be useful for when there are more signals visible than there are channels, or when you find a certain signal seems to get ignored.

Airlink Express is programmed so that no two channels (except for the main channel and an extra channel) will decode the same signal. You may notice that when one channel indicator is getting close to another, that it will back off. This will ensure that not all channels converge on a single strong signal and ignore other weaker signals.
The squelch level which you can set on the level meter controls the squelch level for all channels. Setting the correct squelch level will have a serious impact on the speed of which new signals are acquired. Setting the squelch level to the lowest level will make the signal search slow. Setting it very high may result in lost signals. The best way to set the correct squelch level is by tuning a relatively weak signal with the main channel (green triangle on the waterfall) and then set the squelch level where the level meter just turns green. Usually this is around the 60 to 75% level, but really depends how much signal the sound card is receiving and how high your local noise level is.

As described earlier, the decoded text of each channel will appear scrolling in a field next to the channel indicator.

Since PSK250, some MFSK modes, and RTTY are wider in bandwidth than the other modes and text is being received much faster, only 4 or 2 channels will be available. The text will be shown in a multi line field for these modes so that it is a bit easier to read. Clicking on the decoded text will tune the main channel to that channel so that you follow a QSO on this channel on the main channel.

**Callsign Detectors**

Each channel also has a callsign detector. Whenever a callsign is detected, it will be placed in the field next to the decoded text for that channel. When you click on a decoded callsign field, the main channel will be tuned to that channel and the callsign will be placed in the callsign field on the log bar. This allows you to fire your macros immediately when you spot a rare DX signal.

If you want to clear the channels and callsigns, just right click anywhere on the Multi Channel Display and select **Clear Multichannel Fields** from the menu that appears. This will not clear any information from the log bar, including any callsign that you may have clicked on.

**Automatic Text Searching**

If you wish, Airlink Express can change the background color of a channel on the Multi Channel Display when a certain text is being received on that channel. This can be helpful if you are interested in finding stations calling for “CQ” or if you are trying to find a certain DX station.

To tell Airlink Express to look for such text, use the Multi Channel Search Text option from the Options menu.
A window will pop up allowing you to enter the text Airlink Express should be looking for.

The search is NOT case sensitive. So "CQ" and "cq" are considered the same text. In the window shown above we tell Airlink express to look for "cq". The spaces around the "cq" are deliberate to distinguish the CQ in a cq-call from a CQ in a callsign. Click the OK button when you are done and Airlink Express will start looking for that text on every channel from that moment on.

You still have to tell Airlink Express what the background color should change into be when Airlink Express finds the text you defined earlier. The background color can be defined via the Color option on the Options menu.

Choose a color from the color picker window that will pop up, and from that moment on if Airlink Express finds receives the text, it will change the background color of the channel it received the text on to the color you just defined. In this case we chose the blue color.
The changed background color of a channel will remain as long as the search text is visible. Once the text is not visible anymore, the background color will change back to its original color.
Auto Increment Serial Number

Even though Airlink Express is not meant to be contesting software, there is a feature to aid in contesting. The Auto Increment Serial Number feature can be used if one is making contest contacts where the exchange of an incremental serial number is required.

To use this feature you will have to enable it on the Options menu:

```
Options  |  Help
---------|---------
FFT Scale|         
Color    |         
Font     |         
Callbook Lookup|     
Grab callsigns|       
Display tone frequency|   
Find previous contacts|     
Auto Increment Serial Number|   
Set Receive Sample Frequency|     
Set Transmit Sample Frequency Offset|
```

Once enabled you can enter a number in the SNTX:

```
IOTA:  SNRX:  SNTX  CQZ:

number to be sent
```

As soon as the current contact is logged by either clicking on the save button or by issuing the `<LOG>` or `<LOGANDCLEAR>` macro tags, the number will be incremented:

```
IOTA:  SNRX:  SNTX:

number incremented
```

If this field contains anything else than a number it will not be incremented, however, the information will be stored in the log along with the contact.

The information in the SNTX field of the log bar will also be saved in between sessions, so next time you open Airlink Express, the TX serial number will indicate what it was before Airlink Express was closed the previous time. Even if it is not a number it will be stored in between sessions.
Set Receive Sample Frequency

In order to get the best decoding possible, especially on weak signals, you may want to change the sample frequency at which incoming signals are sampled. You can change the sample frequency by selecting the Set Receive Sample Frequency item from the Options menu.

You will then be asked to select a different sample frequency from the drop down list and you can then adjust it with the up and down buttons next to the drop down list if you wish.

Click the save button to save the selection. The newly selected sample frequency will be permanently stored so that the next time you start Airlink Express it will use the new sample frequency. You do not need to restart Airlink Express to make the new sample frequency active.
Set Transmit Sample Frequency Offset

Airlink Express allows you to specify the transmit sampling frequency offset with respect to the receive sample frequency. To do this, select the Set Transmit Sample Frequency Offset item from the Options menu.

You will then be asked to enter the offset frequency in Hz.

Click the save button to save the offset frequency. The newly selected offset frequency will be permanently stored so that the next time you start Airlink Express it will use the new offset frequency. You do not need to restart Airlink Express to make the new offset frequency active.
Callbook Online Lookup

Airlink Express allows you to lookup callbook information about a callsign online. It uses a free service to do this. The fields that are available on the log bar, including the extended log bar, will be filled out as much as possible with the information obtained from the online service.

Logging into the callbook service

In order to make this option work, you will need a free account on QRZ.com. You do not need a XML subscription from QRZ.com. Enter the username and password of that QRZ.com account on the Operator Information panel:

The password will be stored in encrypted form.

When Airlink Express starts and the callbook lookup function is turned on on the Options Menu, Airlink Express will attempt to log onto QRZ.com using the information you provided above. Airlink Express will notify you off this process at the bottom left of the status bar.

If the username or password information was incorrect or a connection with QRZ.com was not established, Airlink Express will indicate that the login process has failed. The callbook lookup feature will then be disabled.
If everything went OK, then Airlink Express will indicate that the login process was successful and the callbook lookup feature is turned on.

Enabling the callbook lookup feature

To enable this feature, simply select "Callbook Lookup" from the Options menu and it will be activated immediately.

Once you entered a callsign in the Callsign field on the log bar and you leave that field (by using the tab key for instance), or you select a callsign from the receive window or from the multi channel window, the information will be obtained from the online service, if available.

It will take some time to look this information. This depends on the speed of your internet connection and how busy the web site is where the information is obtained from. Especially during contests when the web site is rather busy, it may take quite some time. While Airlink Express is waiting for the information to return from the web site it will display a note indicating this on the status bar.

Once the information has been retrieved, it will be used to fill out the various fields on the log bar.
On the free online lookup service

The provision of this service may be withdrawn without any previous announcement as there is no agreement in place to provide Airlink Express with this service. If this feature stops working, simply deselect this feature from the Options menu. In the future this facility may or may not continue to be featured in Airlink Express as its availability is entirely up to the good will of the provider of the callbook data.

On paid callbook lookup services

Airlink Express is distributed as free software for Amateur Radio Operators and SWL's throughout the world. Introducing a method where payment would provide information about callsigns from an on line call sign look up service was, and is, not my intention.

The provision of such a method would require an investment in time and money, and would enable others to have a monetary gain from this freely available software. Also this would not be acceptable because the providers of the call information on the internet are unwilling, at the present time, to consider reimbursement to Airlink Express to support such a service.
PSK Reporter

You can share with others around the world what you are hearing at your station by using the PSK Reporter feature. PSK Reporter is an automatic propagation reporter whereby your station can send the callsigns it hears to a central server at http://pskreporter.info/pskmap.html.

This feature can be turned on and off with the icon on the log bar. The PSK Reporter feature can only be active when the multi channel display is selected. Whether this feature is turned on or off in the multi channel display is saved with your other preferences so you will not have to turn it on every time you select the multichannel display.

PSK Reporter is developed by Philip Gladstone. For more information on this great feature, please visit http://pskreporter.info/.
Sending and Receiving Files

You can exchange files using Airlink Express error free in the PSK modes. Airlink Express uses the Kermit protocol and is capable of sending and receiving text and binary files (including images).

Depending on the mode used and the conditions under which a file transfer takes place, it can take quite some time to transfer a file. To become familiar with this feature, try a few transfers of very small (< 1kB) files first before trying to transfer larger files.

Experimental

The ability to send and receive files with Airlink Express is experimental. There is no intended purpose for this capability other than just being able to do so. No claims are made as to the accuracy or any other property (throughput etc.) of the transmission or its usefulness in any application. This is for the experimenter to determine.

The Kermit Protocol

Kermit is an open protocol developed by Columbia University (http://www.columbia.edu/kermit/kermit.html). The Kermit protocol implementation in Airlink Express has been build from the ground up without the use of any existing code base. The protocol description on which Airlink Express' implementation of Kermit is based, can be found at: www.columbia.edu/kermit/ftp/e/kproto.doc. Airlink Express adheres strictly to the protocol description, with the exception for the proper identification of the transmissions.

Identification

In order to comply with the American FCC identification requirements, Airlink Express will identify the transmitting and receiving station's callsign in human readable text at the beginning and the end of the file transfer, and every 10 minutes during the file transmission. The identification information is prepended to Kermit protocol packets and will not interfere with the transfer.

Retries and timeouts

A file will be divided in blocks of data and each block will be transmitted individually. If a block is not being acknowledged in time (10 seconds), a timeout will occur and the same block will be retransmitted. A total of 6 attempts (5 retries) are being made to transfer a block of data. If a block of data arrives corrupted at the receiver, the receiver will send a negative acknowledge (Automatic Repeat Request or ARQ) to the transmitter. The transmitter will then retransmit the block of data. If it is not possible to complete the transfer due to changing propagation condition, interference or other causes, the transfer will be aborted.

For an in depth discussion of the Kermit protocol, please see the ketmit Protocol Manual at www.columbia.edu/kermit/ftp/e/kproto.doc.
Sending a file

To send a file, select “Send file” from the Tools menu.

Make sure you have entered the callsign of the receiving station in the Callsign field on the log bar, otherwise you will get an error message. A window will popup allowing you to select the file you would like to transmit.

Select the file you would like to transmit and click the Open button. The transfer of the file will then begin. There will be a short delay before the initial transmission to give the receiving station the chance to get ready to receive the file.

A status window will keep you informed of the progress of the transfer.
At first Airlink Express will try to establish a link with the recipient. This is indicated with the status message “initializing file transfer”. During this initialization phase, various parameters are exchanged with the recipient.

Then it will tell the receiver which file to expect.

Once the link is established the actual file transfer will take place. The name of the file will appear above the progress bar and the progress bar will indicate how far long Airlink Express is in transmitting the file. On the status line it will also indicate which block is currently transferred and how many blocks there are in total.

Once the transfer is complete the link will be terminated.
The status line will indicate the completion of the transfer.

By clicking the OK button you return to the main window of Airlink Express.

You can cancel the transfer at any time by clicking the Cancel button.

If for any reason the transfer cannot be completed, maybe due to changing propagation conditions or interference, the transfer will be aborted.
Receiving a file

To start receiving a file select "Receive file" from the Tools menu.

![Image of the Tools menu with Receive file highlighted]

A dialog box will pop up that will allow you to select a location for the file that you're attempting to receive.

![Image of the Browse For Folder dialog box]

Once you have made your selection, or created a new folder to place the file in, you click the OK button to start receiving the file. Airlink Express will now wait for the transmitter of the file to initialize the transfer.

![Image of the Receive File dialog box]

Status: waiting for initialization
After the initialization Airlink Express will wait for the file header.

Once the initial parameters are received, the file name will be displayed and the progress bar will indicate how far along it is in receiving the file. The status line will indicate how many blocks of data have been received and how many blocks of data it expects to receive.

When the transfer is complete the link will be terminated and the status line will indicate the completion of the transfer.

By clicking the OK button you return to the main window of Airlink Express. You can cancel the transfer at any time by clicking the Cancel button.
Checking for Updates

Please note: always make a backup of your logbook and macros before you upgrade! This is to prevent any loss of important data in case something goes wrong.

Airlink Express can automatically check for updates when it starts and will offer you to install a new version if it is available. To use this feature, make sure that “Check for updates at startup” in the options menu is checked:

If you prefer to manually update, then you can use the “Check for Updates” feature under the Help menu:

Using this feature Airlink Express will check the Airlink Express web site to see if an update is available. If no update is available, it will inform you of this:
If a new version is available it will tell you which new version is available and what version you are running. You can then choose to update Airlink Express or not:

![Check for Updates](image)

If you chose to update Airlink Express it will immediately start the download of the latest version:

![Downloading latest version of Airlink Express](image)

Once downloaded, Airlink Express will give you the option to install it. If you decide not to update, then Airlink Express will delete the file it just downloaded and nothing will change.

If you choose to install the new version, then Airlink Express will close and the installer will run:
Make sure you select the Upgrade option on the "Installation Options" screen so that your logbook and settings will be migrated to the new version. If you select "New Install" then your logbook will be wiped clean and all your settings will be lost.
Follow the instructions on the screen to finish the installation of the new version.
Country, Distance and Bearing Info

Airlink Express will display the country, continent, and short path distance and bearing information when you enter a callsign on the log bar.

When you hover the mouse cursor over a callsign on the Multi Channel Display, it will display the same information in a tooltip:
Importing/Updating Prefix Information

Airlink Express uses the prefix information provided by James J. Reisert, AD1C, which he makes available on his Country Files website.

To update the prefix information in Airlink Express, download the CTY.DAT file from http://www.country-files.com/cty/cty.dat and put it on your desktop, for example. Then go to the File menu in Airlink Express and select the "Import Prefix File" option:

A file dialog window will appear.

Navigate to the cty.dat file you just downloaded and click the "Open" button. Airlink Express will
then process the file and update its internal database with the latest information.

Once finished, click the "Close" button and you're done. There is no need to restart Airlink Express. The update is immediate.
File Menu

Export Log to ADIF  - Export the complete logbook to a ADIF v.2.x file.

Import Log from ADIF - Import a log in ADIF version 2 format into Airlink Express

Backup Logbook  - Backup the logbook in a zip file in a location of your choice

Restore Logbook  - Restore the logbook from a backup you made earlier

Save Macros  - Save the macros in a zip file in a location of your choice

Load Macros  - Load previously saved macros

Exit  - Exit Airlink Express. Settings will be saved.
### Setup Menu

<table>
<thead>
<tr>
<th>Options</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operator Information</td>
<td>Audio Setup</td>
</tr>
<tr>
<td>PTT Serial Port Setup</td>
<td>PTT Parallel Port Setup</td>
</tr>
<tr>
<td>FSK Serial Port Setup</td>
<td>Radio Control</td>
</tr>
<tr>
<td>Band Configuration</td>
<td></td>
</tr>
</tbody>
</table>

- **Operator Information** - Enter your personal information.
- **Audio Setup** - Select soundcard(s) and input and output lines.
- **PTT Serial Port Setup** - Setup a serial port for PTT keying.
- **PTT Parallel Port Setup** - Setup a parallel port (LPT) for PTT keying.
- **FSK Serial Port Setup** - Setup a serial port for FSK keying.
- **Radio Control** - Setup a serial port for Radio Control
- **Band Configuration** - Change the waterfall scale for stations without Radio Control
**Options Menu**

- **FFT Scale** - Select between Squared Amplitude or 100dB scale for the Spectrum Display
- **Color** - Select which color you'd like for the background and text in the transmit and receive windows.
- **Font** - Select which font you'd like for the received or transmitted text.
- **Callbook Lookup** - Lookup callbook information online
- **Grab callsigns** - Turns the "grabbing" of callsigns ON or OFF.
- **Display tone frequency** - Toggles between tone or RF frequency on the watervall and spectrum view
Find previous contacts - When selected the logbook will automatically be searched for previous contacts for a callsign.

Auto Increment Serial Number - Increments the serial number to be transmitted (SNTX field) if this field contains a number and this option is selected.

Set Receive Sample Frequency - Change the sample frequency used to receive signals.

Set Transmit Sample Frequency Offset - Change the transmit sample frequency with an offset to the receive sample frequency.

Check for updates at startup - Turn checking for updates at the startup of Airlink Express on or off.
Help Menu

- **Help Topics** - Select help topics to review.
- **Check for Updates** - Check to see if an update is available and install it if you so desire.
- **Support Airlink Express** - Do you enjoy using Airlink Express? Then go ahead and send me a tip!
- **About Airlink Express** - General information about Airlink Express.
Tool Bar

- Tune, AirLink Express will transmit a tone.
- Transmit/Receive toggle.
- Automatic Frequency Control (AFC) toggle.
- Intermodulation Distortion (IMD) measurement toggle.
- Waterfall/Spectrum Display toggle.
- Toggle Multi Channel Display
- Lock Transmit Frequency
- Lock Receive Frequency

Mode: PSK

- Select operating mode (PSK, QPSK, MFSK, RTTY).

Speed: 31

- Select the speed for the current operating mode

- Select Bandpass Filter (Ultra Wide, Wide, Narrow, Ultra Narrow, or None)

- Replay last 60, 30 or 15 seconds

- Clear received text window

- Clear transmit window

- Toggle Optional Log Bar

- Open logbook